using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(sapien)\b(?!([^<>]*(<img[^>]+>)[^<>]*|[^<>]*)(<\/a|<\/div|>))";
string input = @"<p>sapien Cras cursus consequat nibh <a href=""#"">sapien</a>ac vehicula <div class='test'>sapien</div>. Sed erat sapien, condimentum quis risus nec, viverra dignissim nisi. <div>Cras sapien convallis <img src=> erat </div>, erat egestas tincidunt <img src=""myimage.jpg"" alt=""sapien"">rutrum, massa enim sagittis ante, sapien.sed pellentesque lorem risus vitae enim. Curabitur hendrerit dolor facilisis <a href=""sapien""hhhhhhhhh>sapien</a> dolor malesuada molestie.sapien</p>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}