import Foundation
let pattern = #"\b(sapien)\b(?!([^<>]*(<img[^>]+>)[^<>]*|[^<>]*)(<\/a|<\/div|>))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
<p>sapien Cras cursus consequat nibh <a href="#">sapien</a>ac vehicula <div class='test'>sapien</div>. Sed erat sapien, condimentum quis risus nec, viverra dignissim nisi. <div>Cras sapien convallis <img src=> erat </div>, erat egestas tincidunt <img src="myimage.jpg" alt="sapien">rutrum, massa enim sagittis ante, sapien.sed pellentesque lorem risus vitae enim. Curabitur hendrerit dolor facilisis <a href="sapien"hhhhhhhhh>sapien</a> dolor malesuada molestie.sapien</p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)