$re = '/"([^"])*"/m';
$str = '"123","ABC", "ABC,DEF", "GHI"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);