package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\u3000-\u303F\u3040-\u309F\u30A0-\u30FF\uFF00-\uFFEF\u4E00-\u9FAF\u203B\u4E00-\u9FFF\u3400-\u4DFF]`)
var str = `ディアボリックラヴァーズ or バッテリー`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}