re = /[\u3000-\u303F\u3040-\u309F\u30A0-\u30FF\uFF00-\uFFEF\u4E00-\u9FAF\u203B\u4E00-\u9FFF\u3400-\u4DFF]/
str = 'ディアボリックラヴァーズ or バッテリー'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end