using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=^.{8,}$)(?=.*[a-z])(?=.*\d)(?=.*[A-Z]).*$";
string input = @"Rami123456
Passwordsd23
pass123142";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}