using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=SMS: )\+?\d*";
string input = @"Contact me
Please mention you found my ad on sex-tjejer.com! Thank you!
Call: 0764245243
or
SMS: 0764245243
WhatsApp: +46764245243
Close";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}