import re
regex = re.compile(r"(?<=SMS: )\+?\d*", flags=re.MULTILINE)
test_str = ("Contact me\n"
"Please mention you found my ad on sex-tjejer.com! Thank you!\n"
"Call: 0764245243\n"
"or\n"
"SMS: 0764245243\n"
"WhatsApp: +46764245243\n"
"Close")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")