package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\D.*)\.(\d.*)\.(\D.*)(\d{1,2}).*$`)
var str = `log-name.log.2016-07-14-02.service-name01.gz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}