const regex = /^(\D.*)\.(\d.*)\.(\D.*)(\d{1,2}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\D.*)\\.(\\d.*)\\.(\\D.*)(\\d{1,2}).*$', 'gm')
const str = `log-name.log.2016-07-14-02.service-name01.gz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}