$re = '/^(\D*)\.([\d-]*)\.(\D*)(\d{1,2}).*$/m';
$str = 'log-name.log.2016-07-14-02.service-name01.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);