// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\D*)\.([\d-]*)\.(\D*)(\d{1,2}).*$").unwrap();
let string = "log-name.log.2016-07-14-02.service-name01.gz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}