package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{2,4}?).*$`)
var str = `1234abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}