$re = '/^(\d{2,4}?).*$/m';
$str = '1234abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);