package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)22?5`)
var str = `3.1/2.6
1.00/5.00
12/19
125
1225
12.34
-567.89`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}