$re = '/(Knowledge.*)|(some time knowledge.*)|(data after knowledge.*)/m';
$str = 'Requirements
· Completed or close to completing of relevant Microsoft 365 certifications (Essential)
· Diploma or degree in Information Technology, Computer Studies or a related field (Preferred)
· At least 5 years’ work experience in IT/IT support with minimum 3 years in a Microsoft 365 Engineering/Admin role (Essential)
· Knowledge and experience in administering and supporting Microsoft Windows 10 (Essential)
· some time knowledge and experience in administering and supporting Microsoft 365, Exchange Online, Teams, and other Office 365 tools (Essential)
· data after knowledge and experience in administering and supporting SharePoint Online (Preferred)
· Knowledge and experience in administering and supporting Microsoft Dynamics 365 and Business Central (Preferred)
· Strong team player with good oral and written communication and interpersonal skills (Essential) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);