// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Knowledge.*)|(some time knowledge.*)|(data after knowledge.*)").unwrap();
let string = "Requirements
· Completed or close to completing of relevant Microsoft 365 certifications (Essential)
· Diploma or degree in Information Technology, Computer Studies or a related field (Preferred)
· At least 5 years’ work experience in IT/IT support with minimum 3 years in a Microsoft 365 Engineering/Admin role (Essential)
· Knowledge and experience in administering and supporting Microsoft Windows 10 (Essential)
· some time knowledge and experience in administering and supporting Microsoft 365, Exchange Online, Teams, and other Office 365 tools (Essential)
· data after knowledge and experience in administering and supporting SharePoint Online (Preferred)
· Knowledge and experience in administering and supporting Microsoft Dynamics 365 and Business Central (Preferred)
· Strong team player with good oral and written communication and interpersonal skills (Essential) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}