import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:31(-|-|\\.)(?:0?[13578]|1[02]|(?:Jan|Mar|May|Jul|Aug|Oct|Dec)))\\1|(?:(?:29|30)(-|-|\\.)(?:0?[1,3-9]|1[0-2]|(?:Jan|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec))\\2))(?:(?:1[6-9]|[2-9]\\d)?\\d{2})$|^(?:29(-|-|\\.)(?:0?2|(?:Feb))\\3(?:(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\\d|2[0-8])(-|-|\\.)(?:(?:0?[1-9]|(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep))|(?:1[0-2]|(?:Oct|Nov|Dec)))\\4(?:(?:1[6-9]|[2-9]\\d)?\\d{2})$";
final String string = "01/01/2000\n"
+ "01/Jan/2000\n"
+ "31/01/2000\n"
+ "31/Jan/2000\n"
+ "31.Jan.2000\n"
+ "31-Jan-2000\n"
+ "32/01/2000\n"
+ "32/Jan/2000\n"
+ "01/1/2000\n"
+ "01/Jan/2000\n"
+ "01/1/01\n"
+ "01/Jan/01\n\n"
+ "29/02/2000\n"
+ "29/Feb/2000\n"
+ "28/02/2001\n"
+ "28/Feb/2001\n"
+ "29/02/2001\n"
+ "29/Feb/2001\n\n"
+ "30/04/2000\n"
+ "30/Apr/2000\n"
+ "31/04/2000\n"
+ "31/Apr/2000\n\n"
+ "31/07/2000\n"
+ "31/Jul/2000\n\n"
+ "31/08/2000\n"
+ "31/Aug/2000\n\n"
+ "31/09/2000\n"
+ "31/Sep/2000\n\n"
+ "01/12/2000\n"
+ "01-Dec-2000\n\n"
+ "01/15/2000\n"
+ "01-02-2024\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}