# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:31(-|-|\.)(?:0?[13578]|1[02]|(?:Jan|Mar|May|Jul|Aug|Oct|Dec)))\1|(?:(?:29|30)(-|-|\.)(?:0?[1,3-9]|1[0-2]|(?:Jan|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec))\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:29(-|-|\.)(?:0?2|(?:Feb))\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:0?[1-9]|1\d|2[0-8])(-|-|\.)(?:(?:0?[1-9]|(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep))|(?:1[0-2]|(?:Oct|Nov|Dec)))\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$"
test_str = ("01/01/2000\n"
"01/Jan/2000\n"
"31/01/2000\n"
"31/Jan/2000\n"
"31.Jan.2000\n"
"31-Jan-2000\n"
"32/01/2000\n"
"32/Jan/2000\n"
"01/1/2000\n"
"01/Jan/2000\n"
"01/1/01\n"
"01/Jan/01\n\n"
"29/02/2000\n"
"29/Feb/2000\n"
"28/02/2001\n"
"28/Feb/2001\n"
"29/02/2001\n"
"29/Feb/2001\n\n"
"30/04/2000\n"
"30/Apr/2000\n"
"31/04/2000\n"
"31/Apr/2000\n\n"
"31/07/2000\n"
"31/Jul/2000\n\n"
"31/08/2000\n"
"31/Aug/2000\n\n"
"31/09/2000\n"
"31/Sep/2000\n\n"
"01/12/2000\n"
"01-Dec-2000\n\n"
"01/15/2000\n"
"01-02-2024\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL | re.UNICODE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.