#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d(?= +category)"
Local $sString = "id: N group: 1 category: NAMES : Mike" & @CRLF & _
"id: N group: 2 category: NAMES : Seth" & @CRLF & _
"id: # group: 1 category: PHONE : 123-456-789" & @CRLF & _
"id: # group:2 category: PHONE : 111 111-1111" & @CRLF & _
"id: @ group: 1 category: EMAIL : mike@mail.com" & @CRLF & _
"id: @ group: 2 category: EMAIL : seth@yahoo.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")