import re
regex = re.compile(r"\d(?= +category)")
test_str = ("id: N group: 1 category: NAMES : Mike\n"
"id: N group: 2 category: NAMES : Seth\n"
"id: # group: 1 category: PHONE : 123-456-789\n"
"id: # group:2 category: PHONE : 111 111-1111\n"
"id: @ group: 1 category: EMAIL : mike@mail.com\n"
"id: @ group: 2 category: EMAIL : seth@yahoo.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")