use strict;
my $str = 'a a a a a a a a a a a a';
my $regex = qr/(.+?)(?>\1+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";