$re = '/(.+?)(?>\1+)/';
$str = 'a a a a a a a a a a a a';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;