use strict;
my $str = 'muss der String verändert werden.
Wenn gegen inputB gematched wird, ist die Regex kein Treffer, bei $c1B kann das Backtracking also stattfinden.
Dann habe ich noch Muffis Vorschlag aufgegriffen. In den Fällen $c2A und $c2B wird das Backtracking durch die Look-Behind-Assertion als nker vor dem \\s+ verhindert.
Ergebnis:
lle vier Varianten brauchen auf meiner Maschine mit Perl 5.20.2 ca. 4 Sekunden. Die Unterschiede liegen jeweils innerhalb der Schwankungsbreite zwischen zwei erneuten Durchläufen.
';
my $regex = qr/.*\S(\s+)$/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}