$re = '/.*\S(\s+)$/s';
$str = 'muss der String verändert werden.
Wenn gegen inputB gematched wird, ist die Regex kein Treffer, bei $c1B kann das Backtracking also stattfinden.
Dann habe ich noch Muffis Vorschlag aufgegriffen. In den Fällen $c2A und $c2B wird das Backtracking durch die Look-Behind-Assertion als nker vor dem \\s+ verhindert.
Ergebnis:
lle vier Varianten brauchen auf meiner Maschine mit Perl 5.20.2 ca. 4 Sekunden. Die Unterschiede liegen jeweils innerhalb der Schwankungsbreite zwischen zwei erneuten Durchläufen.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);