using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^noscript\>]<style[^>]*>([^<]+)?<[\s\/]+style>";
string input = @"<!DOCTYPE html>
<html lang=""en-US"">
<head>
<meta charset=""UTF-8"">
<meta name=""viewport"" content=""width=device-width, initial-scale=1.0, viewport-fit=cover"" />
<style type=""text/css""></style>
<noscript><style>
< / style></noscript>
<!-- Twitter Cards Meta by USM STARTS-->
<meta name=""twitter:card"" content=""summary"" />
<style type=""text/css"">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel=""pingback"" href=""/xmlrpc.php"">
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}