const regex = /[^noscript\>]<style[^>]*>([^<]+)?<[\s\/]+style>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^noscript\\>]<style[^>]*>([^<]+)?<[\\s\\\/]+style>', 'g')
const str = `<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, viewport-fit=cover" />
<style type="text/css"></style>
<noscript><style>
< / style></noscript>
<!-- Twitter Cards Meta by USM STARTS-->
<meta name="twitter:card" content="summary" />
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel="pingback" href="/xmlrpc.php">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}