#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<noscript>.*?<\/noscript>(*SKIP)(*FAIL)|<style[^>]*>([^<]+)?<[\s\/]+style>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html lang="en-US">" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <meta name="viewport" content="width=device-width, initial-scale=1.0, viewport-fit=cover" /> " & @CRLF & _
" <style type="text/css"></style>" & @CRLF & _
"<noscript><style>" & @CRLF & _
"" & @CRLF & _
"< / style></noscript>" & @CRLF & _
" <!-- Twitter Cards Meta by USM STARTS-->" & @CRLF & _
" <meta name="twitter:card" content="summary" />" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" <style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>" & @CRLF & _
"" & @CRLF & _
"<link rel="pingback" href="/xmlrpc.php">" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")