import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<noscript>.*?<\\/noscript>(*SKIP)(*FAIL)|<style[^>]*>([^<]+)?<[\\s\\/]+style>";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en-US\">\n"
+ "<head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0, viewport-fit=cover\" /> \n"
+ " <style type=\"text/css\"></style>\n"
+ "<noscript><style>\n\n"
+ "< / style></noscript>\n"
+ " <!-- Twitter Cards Meta by USM STARTS-->\n"
+ " <meta name=\"twitter:card\" content=\"summary\" />\n\n"
+ " \n"
+ " <style type=\"text/css\">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>\n\n"
+ "<link rel=\"pingback\" href=\"/xmlrpc.php\">\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}