package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*?):\h*\"(.*?)\"(?:,|$)`)
var str = `varA: "value, A", varB: "value:B", varC: "value C", varD: "value\"D\""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}