$re = '/(.*?):\h*\"(.*?)\"(?:,|$)/m';
$str = 'varA: "value, A", varB: "value:B", varC: "value C", varD: "value\\"D\\""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);