package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^:]*):\s*(.*)`)
var str = `Registry-Location: htt://something.com:789/pddf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}