$re = '/([^:]*):\s*(.*)/';
$str = 'Registry-Location: htt://something.com:789/pddf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);