$re = '/(?<=\()[^()]+(?=\))/m';
$str = '
text and [a markdown link](https://google.com)
text (and [a markdown link within parenthesis](https://google.com))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);