re = /(?<=\()[^()]+(?=\))/m
str = '
text and [a markdown link](https://google.com)
text (and [a markdown link within parenthesis](https://google.com))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end