use strict;
my $str = 'this-is-a-set-syntax: VALUE
this-is-a-set-syntax: "VALUE"
this-is-a-set-syntax: "VALUE" (sometimes there is quotes)
this-is-a-set-syntax: "VALUE" (sometimes there is quotes)
this-is-a-set-syntax: |VALUE| (sometimes there is no quotes at all)
this-is-a-set-syntax: *VALUE* (sometimes there is no quotes at all)';
my $regex = qr/this-is-a-set-syntax:\s*(?|(["|*])(.*?)\1|()(\S+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}