$re = '/this-is-a-set-syntax:\s*(?|(["|*])(.*?)\1|()(\S+))/m';
$str = 'this-is-a-set-syntax: VALUE
this-is-a-set-syntax: "VALUE"
this-is-a-set-syntax: "VALUE" (sometimes there is quotes)
this-is-a-set-syntax: "VALUE" (sometimes there is quotes)
this-is-a-set-syntax: |VALUE| (sometimes there is no quotes at all)
this-is-a-set-syntax: *VALUE* (sometimes there is no quotes at all)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);