using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";;\(([^;]*(?:;(?!;\))[^;]*)*);;\)";
string input = @";;(
Capture this part, which can contain everything except the closing token
;;)";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}