re = /;;\(([^;]*(?:;(?!;\))[^;]*)*);;\)/
str = ';;(
Capture this part, which can contain everything except the closing token
;;)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end