$re = '@/\*.*\*/(*SKIP)(*FAIL)|".*?"@';
$str = '/** This function returns TRUE if a "line of sight" **/
(tab here) /* Vertical "knights" */
if (g->multiple_objects) {
/* Get the "pile" feature instead */
k_ptr = &k_info[0];
}
put_str("Text inside", hgt - 1, (wid - COL_MAP) / 2);
/* More code "SHOULDN\'T MATCH" *** */
asfas "should match too" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);