// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"/\*.*\*/(*SKIP)(*FAIL)|".*?""#).unwrap();
let string = "/** This function returns TRUE if a \"line of sight\" **/
(tab here) /* Vertical \"knights\" */
if (g->multiple_objects) {
/* Get the \"pile\" feature instead */
k_ptr = &k_info[0];
}
put_str(\"Text inside\", hgt - 1, (wid - COL_MAP) / 2);
/* More code \"SHOULDN'T MATCH\" *** */
asfas \"should match too\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}