$re = '/([^;:<>!?\n\\\\\/]+\@[^;:<>!?\n\\\\\/]+\.[^;:<>!?\n\\\\\/]+)/mi';
$str = 'john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);