re = /([^;:<>!?\n\\\/]+\@[^;:<>!?\n\\\/]+\.[^;:<>!?\n\\\/]+)/mi
str = 'john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com
john.doe@doe.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end