package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]{9}`)
var str = `123456789
654987654987`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}