$re = '/[0-9]{9}/';
$str = '123456789
654987654987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);