#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{%%\}="([^"]+)""
Local $sString = "{%" & @CRLF & _
" function check(a, b) {" & @CRLF & _
" if ($object[a] && (b === undefined || $object[b])) {" & @CRLF & _
" $write("checked");" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"%}" & @CRLF & _
" <tr>" & @CRLF & _
" <td>{{name}}</td>" & @CRLF & _
" <td>{{description}}</td>" & @CRLF & _
" <td><input type="checkbox" {%%}="check('load');"></td>" & @CRLF & _
" <td><input type="checkbox" {%%}="check('load', 'test');"></td>" & @CRLF & _
" <td><input type="checkbox" {%%}="check('doc');"></td>" & @CRLF & _
" </tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")