import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{%%\\}=\"([^\"]+)\"";
final String string = "{%\n"
+ " function check(a, b) {\n"
+ " if ($object[a] && (b === undefined || $object[b])) {\n"
+ " $write(\"checked\");\n"
+ " }\n"
+ " }\n"
+ "%}\n"
+ " <tr>\n"
+ " <td>{{name}}</td>\n"
+ " <td>{{description}}</td>\n"
+ " <td><input type=\"checkbox\" {%%}=\"check('load');\"></td>\n"
+ " <td><input type=\"checkbox\" {%%}=\"check('load', 'test');\"></td>\n"
+ " <td><input type=\"checkbox\" {%%}=\"check('doc');\"></td>\n"
+ " </tr>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}