import re
regex = re.compile(r"^(-\s+)(lat)(.*)(\n\s*)(long)", flags=re.MULTILINE)
test_str = ("- lat: \"-82.645672\"\n"
" long: '44.941747'\n"
" title: \"Item 1\"\n"
"- lat: \"-82.645744\"\n"
" long: '44.940731'\n"
" title: \"Item 2\"\n"
"- lat: \"-82.645744\"\n"
" long: '44.940731'\n"
" title: \"Item 3\"\n"
"- lat: \"-82.646599\"\n"
" long: '44.941441'\n"
" title: \"Item 4\"")
subst = "$1$5$3$4$2"
result = regex.sub(subst, test_str)
if result:
print(result)