using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\shref=['""]\Khttps?://www\.domain\.nl(?:/[^\s""\'<>]*)?";
string input = @"<a href=""https://www.domain.nl/internet"" target=""_blank"" title=""https://www.domain.nl/internet"">https://www.domain.nl/internet</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}