$re = '~\shref=[\'"]\Khttps?://www\.domain\.nl(?:/[^\s"\'<>]*)?~m';
$str = '<a href="https://www.domain.nl/internet" target="_blank" title="https://www.domain.nl/internet">https://www.domain.nl/internet</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);